Jump to content


Photo

Wp_Content_Url Vs Content_Url()


  • Please log in to reply
4 replies to this topic

#1 flamerz

flamerz

    Member

  • MD Customer
  • PipPip
  • 22 posts

Posted 03 March 2016 - 06:44 AM

I have seen Marketers delight theme uses WP_CONTENT_URL instead of content_url().

 

When somebody uses a CDN, there is no way of rewriting the URL to static resources, as a result not every image is pointing to the CDN.

 

More info available at: https://cometcache.c...-resource-urls/

 

With MD theme you can achieve a great score on page speed tests.

 

Here is mine (website on development).

 

This score is not using a CDN. The 96% YSlow score can be improved as you can see on the screenshot.

 

Best regards!

 

Roberto

Attached Files



#2 Alex

Alex

    Kolakube Staff

  • Kolakube Admin
  • 3,484 posts

Posted 03 March 2016 - 12:42 PM

Wow, I'm loving the site design here Roberto! This sounds like a change I'd love to make to MD, where did you find the instance of WP_CONTENT_URL in MD?


- Alex
Check out the Kolakube blog or follow me on Twitter.

#3 flamerz

flamerz

    Member

  • MD Customer
  • PipPip
  • 22 posts

Posted 04 March 2016 - 02:36 AM

lol.. thanks.

 

I hope I was looking the proper place, now I'm from my phone.

 

All the resources loaded as the logo or lead backgrounds are not being loaded on the cdn, seems the path does not point outside.

 

When I insert an image on the page/article it works, is there some code or similar that can force this?



#4 Alex

Alex

    Kolakube Staff

  • Kolakube Admin
  • 3,484 posts

Posted 04 March 2016 - 12:02 PM

I truthfully can't recall ever using the WP_CONTENT_URL constant anywhere in MD (couldn't find it in the theme).

 

For the images issue, it's possible it could have something to do with the way the background images are applied to the Page Leads—it's done by attaching inline CSS to the HTML container (not the best), though the logo is an <img> so I'm not sure if that's a plausible explanation. Which CDN do you use, have you considered contacting them to see if they could shed some light on this? Sorry I don't have a better answer for you right now!


- Alex
Check out the Kolakube blog or follow me on Twitter.

#5 flamerz

flamerz

    Member

  • MD Customer
  • PipPip
  • 22 posts

Posted 04 March 2016 - 02:42 PM

Oh.. I let the plugin guys to access my server. I'm using zencache and maxcdn. I'll investigate more...I'm a happy camper with 99%/96% (without CDN).

 

Pretty good optimization.

 

I forgot to capture my previous design to show you. It was like this one: http://algoritmo.marketing/(but this is on genesis).






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users